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YEAR-END AGENDA

Let’s Have A

Happy New 

Year!

 Resources/Documentation
 Changes for this year (2019/2020)
 Install/Update Notes
 Module Closing Steps
 Closing Questions

Abra Lynne Gilman
25 Years of GP Closing
GP Practice Lead
Collins Computing, Inc.



‘Connect’ area of home page
Where do I find them?

Dynamics GP Connect

on home page

Customersource

Dynamics GP Link

Microsoft 

Year-End Blogs

GPUG Open Forum

Ask your partner!

Year-End Closing Resources

“Learn More” will take 

you to GP Blogs, then 

find ‘year-end blog 

series 2019’

https://community.dynamics.com/gp/b/dynamicsgp/posts/microsoft

-dynamics-gp-2019-year-end-blog-series-schedule

https://community.dynamics.com/gp/b/dynamicsgp/posts/microsoft-dynamics-gp-2019-year-end-blog-series-schedule


Year-End Closing Resources
https://community.dynamics.com/gp/b/dynamicsgp/posts/microsoft-dynamics-gp-2019-year-end-blog-series-schedule

MS Support Blog Series



Year-End Closing Resources
CustomerSource Link
https://mbs.microsoft.com/customersource/northamerica/GP/learning/documentation
/system-requirements/dynamicsgpresource



Who Uses:
Payables – no problem!
Fixed Assets? Luxury Auto only!
Payroll? You can run on new 2020 tax tables ONLY (for now)? 
W/out installing year end update code, you won’t have new W4 2020 window & fields.
When new tax tables or year end update installed all current employee filing status’s will 
remain the same, such as Married, Single, Exempt, etc.
Once an employee fills out a new 2020 W4, that is when you make the changes under 
Cards | Payroll | Tax (or self service) of newly selected filing status/ W4 changes.

• W-4 form change for 2020 Changes for Employee SS W4 form & Cards | Payroll | Tax window 
(required table changes)

• No W-2 or ACA form or EFW2 electronic file changes

• No Payables form changes

• Fixed Asset Luxury Auto Depreciation changes

• New tax tables published based on 15-T Incl New HOH Status, Std & Multi Jobs withholding tax

2019 Pending Year-End Update Changes

Mainstream Support for Microsoft Dynamics GP 

2015 will end on 4/14/2020

Visit this page for more information.

https://nam06.safelinks.protection.outlook.com/?url=https://www.irs.gov/pub/irs-dft/fw4--dft.pdf&data=02|01|theley@microsoft.com|c7c2b0612f064d5d0e8008d75c7c4b34|72f988bf86f141af91ab2d7cd011db47|1|0|637079561211174368&sdata=U4ZvLxfmOWL6jwtMMA/NMd3xTkIn9N2LlTtrVXI%2BoGQ%3D&reserved=0
https://nam06.safelinks.protection.outlook.com/?url=https://www.irs.gov/forms-pubs/about-publication-15-t&data=02|01|theley@microsoft.com|c7c2b0612f064d5d0e8008d75c7c4b34|72f988bf86f141af91ab2d7cd011db47|1|0|637079561211174368&sdata=pHxFHKUqfUBRUA3qk1Gq4ujRe1Ql%2B3LiKlh9qaPcYEE%3D&reserved=0
https://nam06.safelinks.protection.outlook.com/?url=https://community.dynamics.com/gp/b/dynamicsgp/archive/2016/03/24/microsoft-dynamics-gp-2016-lifecycle-and-upgrade-services&data=02|01|theley@microsoft.com|c7c2b0612f064d5d0e8008d75c7c4b34|72f988bf86f141af91ab2d7cd011db47|1|0|637079561211184326&sdata=4/RHXWVwx7SRV%2Be4RQsdc%2BiMZ95BJWq2C9nd4hbK4aw%3D&reserved=0


Updates/Closing - What’s it all mean?
2019 Payroll Tax Update: Tax Update (minutes)/2020 Code below

Full Year Tax Updates

Year-End Update (Please Call Partner to Assist/Schedule)
Program Updates: Need to update server/workstations
Within same version only – Available Week of Nov 18th

Year-End Closing (Follow steps to close modules)

2020 Payroll Tax Update: Update to Tax Tables and boxes
2020 Tax Update (Round 1) – Target Mid December
2020 Round 2 Tax Update will be available mid-January 2019.
Update after last Payroll Run of 2019

Upgrade wanted from previous.. 2013, 2015, 2016, 2018?
Major configuration and structure changes/3rd parties affected
Partners Usually Recommends TEST Upgrade

** No “Tax or Year-End” Updates Available for GP 2013, 2010, 10, or prior.

Tax Changes

YE Code Updates GP
2015/2016/2018

Closing Steps

Next Year Changes

Upgrades



What Release Are You On?
GP 2018/GP + Year-End Update = 18.2 (Latest Release Nov 18th 2019 prior 18.2.1013 Oct 2019)

GP 2016 R2 + Year-End Update = TBD (Last Hotfix 9/3/2019 = 16.00.0788)

GP2015 R2 + Year-End Update = TBD (Last Hotfix 9/3/3019 = 14.00.1207) – Last one 4/14/2020

GP2013 No more updates (Last Release Jan 25, 2018 12.00.2230) – Support ended 4/10/2018

GP 2016+
GP 2018+

GP 2016+

GP 2015+



Steps to Closing the Year 
Start with Subsidiary Modules

Sales Order/Purchase Order/MFG/FS/BOM

Inventory, Project Accounting

Payroll & Human Resources (We’ll cover last)

Payables, Receivables, Fixed Assets

Analytical Accounting & General Ledger

Which modules 

do you all have?



Prepare Modules 
Finalize Transaction Postings

Reconcile GL to Subsidiaries

Print Reports

Backup



Distribution Year-End: Inventory
When should the close be done?
After you ‘validate’ the modules that post to Inventory.

Enter and post all Purchase Order Processing, Invoicing/Sales Order Processing, & 
Inventory transactions for current year

Run POP Received/Not Invoiced report to tie to A/P Liability account. Reports > 
Purchasing > Analysis > Received/Not Invoiced



“Other” Modules Ready for Inventory Close?

Post all transactions for the year for:

Purchase Order Processing

Project Accounting

Sales Order Processing

Bill of Materials

Field Service

Manufacturing

Reconcile SOP/POP modules.  

Utilities > Purchasing > Reconcile Purchasing Transactions

Utilities > Sales > Reconcile / Remove Sales Documents



Inventory year end

 Transfer summarized current-year quantities, costs, and sales 

information (Dollars/Quantities)

 Update Beginning quantity of each item from On Hand quantity at each 

site. (Turnover Report—uses beginning #)

 Reset the Quantity Sold field for each item to zero.

Options to: 

 Remove purchase receipts for items completely sold.

 Remove discontinued items from items completely sold.

 Remove lot attributes for items completely sold.

 Updates standard cost of item to the current cost if using FIFO or LIFO 

periodic valuation methods.

 Remove Cost Change History.

Closing the Year in Inventory will:



Inventory Card history

Quantities and Amounts 

moved to “Last Year”



Year End Steps for Inventory
 Reconcile Inventory quantities. 

Utilities > Inventory > Reconcile

 (Optional) Complete a physical inventory count &  post adjustments. 
Reports-Inventory-Activity-Physical Inventory Checklist

 Print inventory reports for records (if applicable):

 Make a backup.

 Close the Inventory Module year 
Tools > Routines > Inventory > Year-End Close



Serial/Lot Numbers syncing issues

Running Inventory Checklinks/Reconcile may create new
records in Serial Master table that represent missing 
serial numbered items.

The system will create new serial numbers but these will 
not match your inventory. Edit the records in the 
Serial Lot Master table to correct serial numbers.

You can also simply add records to the Serial Master table 
for the missing serial numbers.

This can also be done for missing lots.



Physical/Stock Counts Process
Stock Calendar Maintenance

Dates for next stock count for  item-site combo. 
GP > Tools > Inventory > Setup > Stock Calendar

Stock Count Cycle Assignment
Assign one stock count frequency to many items. 
Cards > Inventory > Cycle Count Assignment

Stock Count Schedule  
Qty on hand for each line in stock count schedule captured. 
Later, actual count qty compared to captured values to create default variance 
transactions. 
Transactions  > Inventory  > Stock Count Schedule

Stock Count Forms can be printed during this process. 

Stock Count Entry 
Window to enter results of stock counts. 
When stock count is processed, variance transactions are created.
Trx will also post IF  Auto-post Stock Count Variances box checked. 
Transactions >Inventory> Stock Count Entry



Stock Count Screens 



Stock Count - Manually Adjust
Manual Process:

Print a Physical Inventory Checklist. then perform a physical count of your Inventory, verify # on 
hand accurate for Items. 

Reports > Inventory > Activity

Then Manually create Inventory Transaction of differences for each item.

Transactions > Inventory > Transaction Entry

NOTE RE: POST TO GL CHECKBOX ON BATCH SCREEN  (DEFAULTS ON).



Automated Stock Counting: SalesPad Data Collection

DataCollection provides an easy to deploy & use 
mobile bar-code data collection solution.

Manage materials within a warehouse or across  
sites.  Easily create Bin Transfers, Site 
Transfers, and Inventory Adjustments. 

Allows users to easily enter Stock Counts 
supporting GP’s standard inventory counting 
functionality.



Tools > Routines > Inventory > Year End Close

Released in GP 2013: 

Updating Standard Costs DOES create a GL 
entry/batch to reflect inventory valuation 
change.

Otherwise, prepare entry manually by 
referring to pre- and post-close Stock Status 
reports to determine the valuation change.

Summary windows in inventory with specific views of calendar or fiscal year are date-sensitive. 
**The inventory year end close process is not date-sensitive. (Turnover reports will be incorrect if close late)



Historical IV Trial Balance
Don’t see Historical IV Trial Balance under

Reports > Inventory > Activity menu?
You may need to install it. 
(and use the HITB Inventory Reset Tool.) Contact a support desk!

Balance the General Ledger 
to the Inventory Module 
“As of” a particular date!



Receivables Management Closing

May want to close prior to posting transactions in next 
calendar year. 
Transfers finance charges to the last year (LY) field on the 

customer records. 
(Need to print finance charges on the Dec & Jan customer 
statements.)

*Finance charges do not automatically print on the customer 
statements so report needs to be modified to include this 
information.

May want to close prior to posting any transactions in the 
next fiscal year. 
Transfers all other amounts to Last Year “buckets”

Calendar 
Year-End

(Finance 
Charges 

Only)

Fiscal 
Year-End



Receivables: Customer Summary Screen 
Fields Updated
Cards > Sales > 
Summary

Quantities and 

Amounts 

moved to “Last 

Year”

https://support.microsoft.com/en-us/help/3193375/amounts-since-

last-closed-view-in-customer-or-vendor-summary-reflects

Scripts 
available to fix

“Amounts 
Since Last 

Close” 
in summary 
screens.

https://support.microsoft.com/en-us/help/3193375/amounts-since-last-closed-view-in-customer-or-vendor-summary-reflects


Receivables  Year End Procedures
Post trx for year & complete month-end processes (don’t have to post 
‘recurring’).

Make a backup / Close the year

Tools > Routines > Sales > Year End Close

Choose Fiscal/Calendar/Both
Look at the Closing Date! DO NOT hit process 

button twice or it  will close again! 
Last Year #s will zero out

.



Closing Company Tax Details
After closing BOTH AP AND AR MODULES!! 

Tools>Routines >Company >Tax Year End
Select Close Year check box AND/OR Print Report. Click Process. 

When prompted to continue with the year-end close, Click Yes.

Recommendation: Keep copy of year-end report w/ permanent year-end audit records.

Need to Modify $ Amounts in fields?  
Go to: Tools > Setup >Company > Tax Details



Calendar Year End 
When: Close at end of Calendar year, don’t have to do prior to 
posting transactions in the next Calendar year
What - 1099 Amounts YTD cleared, move to LY and LTD

Fiscal Year End 
When – Close at end of Fiscal year, don’t have to do prior to 
posting transactions in the next Fiscal year
What - Vendor Yearly Summary Figures are moved to History –
updates LY and LTD

Closing the year will affect Summary Screens, Smartlists, and 
Reports showing yearly (this year, last year fields).

Payables Year-End Closing

Scripts available 
to fix

“Amounts Since 
Last Close” 
in summary 
screens.

https://support.microsoft.com/en-us/help/3193375/amounts-since-last-

closed-view-in-customer-or-vendor-summary-reflects

https://support.microsoft.com/en-us/help/3193375/amounts-since-last-closed-view-in-customer-or-vendor-summary-reflects


Payables Vendor Summary Views



Payables Management Year-End Steps

 Post all transactions for calendar year to close (2019).

 Put trx for new year (2020) in batches, you can post if you want.

 Print Reports>Purchasing>Trial Balance—Aged Trial Bal w/ Options

 Print the Vendor Period Analysis Report (newer suggestion)

 Print 1099 Statements using the Print 1099 window 

Tools > Routines > Purchasing > Print  1099 

 Do Backup “Post-1099 edits” 

 Close the year

 Close the fiscal periods

 Close the tax year

 Make a Back up named “Post Year End”



1099 Vendor Information 
When AP invoices w/ 1099 figures are paid, 1099 amount is updated.  

Verify 1099 Data w/Smartlist: Vendors with 1099 yes (& Tax Reg Blank/UDF2 for W-9 yes!) 

or Shawn’s Smartlist view: https://lifehacks365.com/2017/12/18/1099-year-end-edit-sql-

view-for-dynamics-gp/

Print Edit List of 1099 Vendors: Tools > Routines > Purchasing > Print 1099 icon

Inquiry Vendor Period Report

https://lifehacks365.com/2017/12/18/1099-year-end-edit-sql-view-for-dynamics-gp/


Payables Management Year End

Important points to remember (2013+) 
• Separate 1099 Address ID field on vendor card

• Additional Box Numbers added for each Tax Type

• Additional fields on the 1099 Details window

• New functionality to edit 1099 information:
• Edit 1099 Transaction Information window (per trx)
• Update 1099 Information utility now has options for ‘Not a 1099 

vendor’ tax type (per vendor)

• Print 1096 Summary Form

Vendor Maintenance Card > Options Tab

Mark Vendor as the specific 1099 type

Change box to fit requirements



Update Vendor 1099 Information
Edit 1099 Trx info, see detailed transactions for a 1099 vendor & 
change the individual trx info to ensure accurate 1099s.

Purchasing Area > Transactions Menu > Edit 1099 Transaction Information



Make vendor 1099 after transactions entered!
Purchasing Area > Utilities Menu > Update1099 Information

Modify a vendor to make them a 1099 vendor 
AFTER documents have been posted! (Or change 
the 1099 type – or make them NOT a 1099 
vendor)



Printing your Company 1099’s
Tools > Routines > Purchasing > Print 1099

For an 
Edit List –
hit the 
printer 
icon!

To Print 
1099’s hit 
PRINT 
FORMS

GP2013+ 
you can 

print 1096 
forms too!

NO LINES – have to use pre-printed forms.  
Vote to have forms print boxes 



How much do you have to spend with a 
vendor to have 1099’s print?

Only vendors marked as “1099 Vendors” AND with have over 
$x in 1099 setup window will print.

Most Miscellaneous set to $600, others set to $10 or 1 cent.

Go to Setup > Payables Setup and then the 1099 Setup button 
to review/change.



Print Period Analysis Report (& email) 
Reports > Purchasing > Analysis > Period



Tools > Routines > Purchasing > Year End Close

 Calendar year 

 Fiscal year 

 All (Both)

Close tax year too…

Closing the Accounts Payable Module



Databases Getting large?
Inquiry/Reporting slowing down?

Start the New Year with 
improved GP performance and 
increased productivity with the 
help of CDA.

Just ask for a demo or trial keys.

Company Data Archive



Project Accounting Year End

 Projects can span multiple fiscal periods. 

 Additionally, projects are independent of the 
fiscal and calendar year. 

Optional: Perform the following procedures as part 
of basic year-end process: 

 Post all cost transactions. 
 Run final billings & revenue recognition on projects for 

the year. (so GL module is updated before you run year-
end routine in GL). After doing this PA & GL will reconcile 
more quickly/easily. 

 Update the rate tables in PA Position Rate Table 
Maintenance and PA Employee Rate Table Maintenance 
windows.

No Specific 
Year-End 

Process for 
Project 

Accounting



Fixed assets closing results
Inquiry > Fixed Assets > Book

Asset General Window:
• YTD Maintenance amount is removed 
• Qty is copied to the Begin Qty field
Asset Book Window:
• YTD Depreciation Amount is removed
• Cost Basis is copied to Begin Year Cost
• LTD Depr moved to Begin Reserve
• Salvage is copied to Begin Salvage

Book Setup Window
- Current Fiscal Year is updated to new year
Do NOT manually change this year to post 
a new asset into the new year,  you will 
damage data!
Just take the time to close the year!



PRIOR to Fixed Asset Year-End Close

 Enter ALL transactions for the year. (AP, Transfers, etc)

 Close ALL books before you can process in new year.

 Fiscal Year End only

 Run depreciation for the final period of the year. 

Run depreciation through the last day of the year.

Tools>Routines>Fixed Assets>Depreciate

 Run the General Ledger Interface (Automatic in GP 2013)
Date should fall within the current fiscal year that is being closed. 
(OLD Version - Tools>Routines>Fixed Assets> GL Posting)

Last module closed 
before GL 

(AFTER A/P!)



PRIOR to Fixed Assets Year-End Close
 Run the following reports:

 Ensure that the Fixed Asset Calendar is built correctly
Tools>Utilities>Fixed Assets>Build Calendar

 Verify Quarters setup for all Fiscal Years
Tools>Setup>Fixed Assets>Quarters

 Run a backup!

Depreciation Ledger
Property Ledger 
Annual Activity
Additions
Retirements

If more than one year 
also run Book to Book 
YTD COMPARISONS

Run reports

Build 
Calendars

Verify 
Quarters

Run Backup



Year End Steps Fixed assets 

Verify Current   
Fiscal Year on    
Available Books list 
is correct.
Tools>Setup>Fixe

Select each book  
Insert that book 
Click continue

 Run year end routine

Tools>Routines>Fixed Assets >Year End

** A report WILL BE generated from this process from GP 2015 R2+



Fixed Assets Year-End Report

A Fixed Assets Closing report now prints w/ year-end close process.

Prints per Book.

Shows:

Asset ID, Description, Cost Basis, YTD depreciation, Accumulated 
Depreciation, NBV, Placed in Service Date, Depreciated to Date, 
Quantity, YTD maintenance and Status for all assets impacted by year-
end close.

Single Step – Close Year/Print Report!



Analytical Accounting Notes

Don’t underestimate the importance of AA matching GL amounts.  
**Scripts to verify AA data against GL

Management Reporter (Data Mart) reads from AA tables

AA Codes automatically close when GL is closed.

If AA is being used, be sure it is installed and enabled on 
workstation where GL is being closed!



Analytical Accounting Year End Scripts
• PRIOR to closing GL: Verify records are not duplicated:

select distinct(YEAR1) from AAG30000 
select distinct(YEAR1) from AAG40000

• PRIOR to closing GL – see that top 2 & bottom 2 match:
select distinct(YEAR1) from AAG30000 
select distinct(OPENYEAR) from GL20000 
select distinct(YEAR1)from AAG40000 order by YEAR1 
select distinct(HSTYEAR) from GL30000 order by HSTYEAR

• Be sure the following returns no results:

select count(*) from AAG40001 where aaCopyStatus<>8 

• Option (setup) to have BBF entries on dimensions

AA data closes 
with GL regardless 
of whether options 
on dimensions are 
marked



Analytical Accounting Close Setup
In the Analytical Accounting Options window option should be 

checked as illustrated below.

GP > Tools > Setup > Company > 
Analytical Accounting > OptionsCheck box to

“Include 
dimension in 

year-end 
close”



Analytical Accounting Dimension setup
Once AA closing is enabled, define “Consolidate balances during Year End close” option for 

every transaction dimension in the system.

Cards > Financial > Analytical Accounting > Transaction Dimensions

Don’t miss marking this 
for any dimension as it 
will not close during 

the year end process.



 Closes P/L to Retained Earnings

 Pushes B/S account balances to new year.
Only RE B/S accts will have a diff BB than previous year’s ending 
balance.

In GP 2013, choose to Unit Accounts roll forward or clear!

 Moves open year $ to historical year  (GL20000 to GL30000)

 Fiscal Year is marked as historical.
 AA tables are updated. Moves AA data to history & creates BBF 

entries on dimensions
 GP 2013: Option remove inactive accounts – or leave those w/ budgets.

General Ledger Closing
What does GL Closing do?



General Ledger Closing

 General Ledger closing does not have to be done right at year end.  
**BUT setup new year & periods to process trx for new year.

 Have all users exit during the closing process.

 Enough disk space to double GL20000 in size.

 Recommended* - Run GL close at server or won’t lose connection.

 Last module to close (Reverse Now available!)  

GL Close 
Key points 



1. Complete posting/closing for other modules.  

2. Post final adjusting entries in GL

3. Print Account List or Smartlist to verify Posting Type

4. Close the last period of the fiscal year (Optional)

Setup > Company > Fiscal Periods

Year End Steps for GL Closing



Year End Steps for GL Closing (cont.)
5. Make sure Maintain History for Accounts & Transactions is marked.

Tools > Setup > Financial > General Ledger

6. Perform File Maintenance on all Financial files – Have users out of system, 
this may take awhile! 

File > Maintenance > Checklinks

** Retained Earnings Acct 
WITH option to close to Div. 

Segments.

** Also can choose the NEXT 
Journal Entry to use 

(Some companies choose “20-
000000” to start a new year)



Year End Steps for GL Closing (cont.)
7. BACKUP!

8. Print final Detail Trial Balance 
Reports > Financial > Trial Balance > Detail

9. Print final financial statements (FRx, Mgmt Rept, AdvFin)

10. Set up new year in Fiscal Periods Setup.
Tools > Setup > Company > Fiscal Periods

11. Close the fiscal year. 
Tools > Routines > Financial > Year end closing



GL Year End Closing Screen
If you don’t select anything, it will NOT remove unused 

segments and it WILL delete all inactive accounts.

To ONLY keep inactive 
accounts that have 

Budgets, 
select Maintain with 

Budgets.



TIPS to dodge a GL Support Call

 Make a copy of your LIVE system into TEST and run a BETA 
Close in TEST.  Make Backups!! Make Backups!!

 Check Account Types (Profit & Loss/Balance Sheet)

To fix this: Account not set with correct posting type? TK  
#864913.  

 Adjusting Entries Needed?

 Go to fiscal period setup. Tools>Setup>Financial>GL

 Uncheck the particular month 

 Set allow posting to history

 Make the entry AND re-check the month you opened.

Yes, you can post 
adjusting entries to the 

closed year.

(But not 2 years back!).



External auditors usually ask for a list of all GL entries:
• Posted for the year, 
• Who posted them, (THIS FIELD ADDED TO SCREENS IN OCT 2019)

• When they were posted 

Use Account Transactions SmartList, filter for Financial 
Transactions, & add Columns:

• User Who Posted (User ID of whoever posted trx)
• Originating Posted Date (Sys date)
• Reference (GL Description, WHY entry was made)

- Starting In GP2013, now an approval ID/Date for Batches!

AUDITORS REQUEST (Smartlist)

SOP Posting is different.

Use USER2ENT =  User ID  
entered trx

PTDUSRID shows User ID 
who  posted final invoice.

These are in SOP10100.



Payroll year-end checklist 

1. Verify your version of GP. 
2. Download Payroll Tax updates for THIS year (2019).
3. Complete all pay runs for the current year 
4. Complete your company’s regular monthly/quarterly 

payroll procedures for the current year (SUTA/FUTA, 
WC, Form 941)

ALWAYS at 
Calendar Year-End

5. Make a “Pre Year-End Wage File” backup. 
6. Create the Year-End Wage file 

Tools>Routines > Payroll 
> Year-end Closing 



Payroll year-end checklist (Continued)
7. Make a backup of new file  (named “Post Year-End Wage Table”)
8. Verify W-2 & 1099-R statement info (Note: If any changes are made to 

the statement information , make another backup).
9. Print the W-2 statements, W-3 Transmittal form, 1095-C, 1094-C 

Transmittal

* Edit W-2 info if necessary 
Tools>Routines >Payroll>Edit W-2s

Tools > Routines > 
Payroll >

Print W-2

Select Radio Button 
that you need (W-2, 

1094, 1095)



Payroll year-end checklist 
(Additional Items)
10.  Print the 1099-R forms, 1096 Transmittal form
11. Print Form 8027 

Tools > Routines > Payroll > Print (or Edit) 1099-Rs or Form 8027
Click on whichever radio button needed, hit print.

** You can print the 
these as many times as 
necessary



12. Optional – Electronic Filing

Tools > Routines > Payroll > 
Electronic File
- Select Appropriate Companies,  
- Enter User ID Number, 
- Click Submitter.

The Electronic Filer Submitter 
Information window opens. 

- Enter the authorized submission 
information. 

- Close Electronic Filer Submitter Info
- Change file destination info in the 
File Name field if it is required. 

- Click Create File

Payroll year-end checklist – Electronic Filing

Company > 250 
employees?

Social Security 
Administration 

requires you to create 
& submit federal W-2 

wage reports 
electronically!



Payroll year end checklist (Optional)

13. (Optional:) Archive inactive employee HR info.

Tools > Utilities > Human Resources > Archive Employee

14. (Optional) Close fiscal periods for payroll series for 2019.
15. (Optional) Delete Inactive employee info. (To save disk 

space, but do AFTER creating Year End wage file).
Tools > Utilities > Payroll > Remove Inactive

Old Issue before Payroll Unlimited:
Inactive do NOT count as ‘active’ 
employees in license count.



16. Set up fiscal periods for 2020
Tools>Setup>Company>Fiscal Periods

17. Install the payroll tax update for 2020
Confirm update – GP > Maint > U.S. Pay Update 

> Check for Payroll Tax Updates
> Automatic – Next 
> Enter Authorization # (Login) > Finish

18. Setup Attendance for new year 

(Reset with Mass Update)
Tools > Setup > Human Resources > Attendance >>Setup

Or  Tools >>Utilities >>Payroll >>Mass Update

19. Update Local tax and Unemployment Tax rates.  

20. Run first 2020 payroll.

Payroll year end checklist (continued)

Now this window opens 

FULL screen! (Oct 2019)



Do you Need to: Run Paychecks in 2020, 
Prior to closing 2019?

 Do steps 1-7 on the left (from Previous checklist)

 Set up Fiscal Periods for 2020

Tools>Setup>Company>Fiscal Periods

 Install the payroll tax update for 2020

 Process 2020 pay run (user date must be 2020) 

 THEN PRINT ALL YOUR FORMS
 Print W-2 / W-3 Transmittal form 

 Print 1099-R /1096 Transmittal form 

 Print Form 8027

 Create magnetic media/Inactivate employees

 Archive Employees

 Setup Attendance

1.  Verify Version #.
2. Download Payroll Tax updates 

for 2019.
3. Complete all pay runs for the 

current year
4. Complete all monthly/quarterly 

payroll procedures for 2019.
5. Make a backup of the original 

file 
6. Install the Year-End Update 
7. Create the Year-End file 



Affordable Care Act Compliance/Reporting

ACA 
Compliance

Reporting 

& BI Tools

Use Third Parties: INTEGRITY DATA or GREENSHADES



www.greenshades.com

The E-File Wizard automatically extracts 
info  from GP & creates E-Files suitable for 
filing to tax and non-tax agencies. 
GreenShades can E-File each of the reports 
below as well as custom reports your 
company may need:

State Filings (SUTA and W2)
State New Hire Reporting
Federal 1099
Federal W2s
Local W2s
940 and 941 Reports
401(k) Reports

http://www.greenshades.com/
http://www.greenshades.com/pub/downloads/documentation/slicks/2007inserts/states.pdf
http://www.greenshades.com/pub/downloads/documentation/slicks/2007inserts/NewHire.pdf
http://www.greenshades.com/pub/downloads/documentation/slicks/2007inserts/1099.pdf
http://www.greenshades.com/pub/downloads/documentation/slicks/2007inserts/FedW2.pdf
http://www.greenshades.com/pub/downloads/documentation/slicks/2007inserts/Locals.pdf
http://www.greenshades.com/pub/downloads/documentation/slicks/2007inserts/94x.pdf
http://www.greenshades.com/pub/downloads/documentation/slicks/2007inserts/401(k).pdf


Questions?



The Following Slides are Direct 
from Microsoft Support Team:
Regarding Regulatory Changes



Equal Employment Opportunity (EEO)

New Pay Band report for 
September Filing

Need to install September 
Hotfix

How to complete report in 
GP

 EEOC has since dropped 
the pay requirement?!?!

https://community.dynamics.com/gp/b/dynamicsgp/posts/microsoft-dynamics-gp-july-hotfix-2019-mid-year-tax-update-released
https://community.dynamics.com/gp/b/dynamicsgp/posts/new-equal-employment-opportunity-eeo-report-with-pay-bands
https://www.shrm.org/resourcesandtools/legal-and-compliance/employment-law/pages/employers-should-review-eeo-1-guidance-before-pay-data-reporting-deadline.aspx


New W4 for 
2020

 Why the change?

 Tax Cuts & Jobs Act of 2017

• Eliminated personal “exemptions”

• Doubled the standard deduction

• Increased child tax credits

• Eliminated &/or restricted several 
itemized deductions

• SALT (State & Local Tax)

• Mortgage Interest

• Charitable Contributions

• Other Deductions (e.g. 
Unreimbursed employee expenses & 
Tax prep fees)

https://www.irs.gov/pub/irs-dft/fw4--dft.pdf


New W-4 for 2020 – Common Questions

 What’s Pub. 15-T?

 No more “Circular E” Section 17?

 Are employees required to complete new form?
 Yes

 Can employers require employees to complete a new form?
 Yes

 Will Federal W/H change if the employee does not complete a new W-4 
for 2020?
 Yes, but no more so than in years past due to tax table changes

 Are these changes final?
 Almost – some minor tweaks due end of November for W-4 / December for 15-T

 What’s the Withholding estimator?
 Used by taxpayers with more “complicated” tax situations (webinar coming from IRS)

https://www.irs.gov/forms-pubs/about-publication-15-t
https://apps.irs.gov/app/tax-withholding-estimator


New W-4 for 2020 – “Old” form



New W-4 for 2020

• No more exemptions
• “Multiple Jobs” = Higher tax

tables
• Line 3: “Dependents” credit
• Line 4a: “Other Income”
• Line 4b: “Deductions”
• How do I file “Exempt” or

or “NRA” (Nonresident
Alien)?



New W4 for 2020 – What is GP doing?

 Tax tables will have new filing 
status

All employees default current

Use Withholding estimator

Warn exemptions default

 Table changes required

 Install 2019 Year End & 
2020 Tax Tables

https://apps.irs.gov/app/tax-withholding-estimator


New W4 for 2020 
– What is GP 

doing?

• Example of 
Cards | Payroll | Tax

• New field Dependent 
Claim Amt



THANK YOU 
FOR ATTENDING!


